Agent delete capability is down
Incident Report for Ensemble Travel Group
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 16, 2018 - 16:42 UTC
Identified
Agents currently cannot be deleted by HomeAdmins, we are working on the issue.
Posted over 1 year ago. Mar 16, 2018 - 15:48 UTC